Pokud se Vám nápověda nezobrazuje korektně, klikněte ve vlastnostech souboru na ODBLOKOVAT


Otvírák

ve spolupráci s


Základní okno aplikace

Základní okno aplikace Otvírák / BeHere po přihlášení

  1. zobrazí rychlé volby uživatele
  2. rozbalené hlavní menu programu, kliknutím pravým tlačítkem myši lze pomocí volby Rozbalit vše zobrazit všechny možnosti
  3. zobrazení přihlášeného uživatele, možnost rychlé změny hesla
  4. po kliknutí lze zobrazit informace o verzi a licenci, platnost licence a povolené Addiny


Obecná práce nad tabulkou

Obecná práce s daty nad tabulkou

např. osob

    1. tlačítko pro založení nové osoby
    2. tlačítko. pro opravu údajů v kartě osoby
    3. tlačítko. pro smazání osoby z programu
    4. tisk resp. výpis tabulky osob s možností exportu např. do XLS
    5. otevření tabulky je statické, tj. pro načtení aktuálních změn je třeba pohled aktualizovat
    6. vyvolá čtení z lokální čtečky čipů a po přiložení čipu vyhledá osobu s daným čipem (pokud existuje)
    7. slouží ke sloučení více osob v případě, že je po importu z cizího systému osoba zadána duplicitně (např. ve ŠkolaOnLine má zaměstnanec více úvazků).
    8. aplikace hromadných změna nad tabulkou Osoby (zadání úvazku, změna kategorie nebo třídy)

Po kliknutí na symbol filtru [image] v záhlaví je možno filtrovat záznamy v tabulce

Kliknutím na záhlaví např. je možné (tam kde to program podporuje) řadit data v tabulce vzestupně či sestupně. V programu jsou data defaultně řazena dle abecedy (až na výjimky – např. tabulka Svátky).


Příkladová data

Příkladová data

aneb jak porozumět základnímu nastavení programu

- v programu je v rámci instalace základní nastavení konfigurace pro typický provoz školního zařízení, což znamená předdefinovaný scénář

- zóna Celá škola - typicky není třeba více zón (pokud nemáme různá odloučená pracoviště apod.) a tato položka je ve výchozím stavu skrytá

- Oblasti

Přístupy někam můžeme řídit buď na úrovni jednotlivých Identifikačních zařízení (čteček), nebo si více těchto zařízení sloučit do Oblasti a potom není třeba při definici oprávnění přístupu vyjmenovávat konkrétní zařízení.

Prostory školy, kde jsou dvoje dveře (tj. dvě řídící jednotky Hlavní vchod a Boční vchod) a ke každé jsou připojeny dvě Identifikační zařízení pro příchod a odchod.

Tělocvična s jednou řídící jednotkou a kvůli evidenci odchodu nájemců vybavena oboustranně čtečkami

Jídelna s jednou řídící jednotkou a jednou čtečkou, protože zde typicky není třeba evidovat odchody, ale jen řídit oprávnění pro příchod

- Kategorie (dle abecedy)

Admin - kategorie pro osoby s nejvyšším oprávněním - v našem případě osoby Admin a Padmé Amidala. !!! Důležité upozornění: nikdy nemažte osobu Admin !!! Osoby v této kategorie (popř. s touto rolí) mají plný přístup do všech oblastí i identifikačních zařízení

Cizí jídelna - určeno typicky pro osoby z ulice, které se stravují ve školní jídelně a jejich role Cizí jídelna (resp. Týdenní rozvrh Cizí jídelna) umožní přístup do oblasti Jídelna pouze v časovém okně 10:30 - 12:00 a jinak jim neumožní přístup do žádné jiné oblasti

Cizí návštěvy - určeno pro návštěvy školy (např. servisní techniky různých automatů, kontroly apod.), kterým jejich stejně pojmenovaná role umožňuje přístup v určitém časovém okně nikoliv dle oblastí, ale jen vyjmenovanými identifikačními zařízeními - tedy Hlavní vchod příchod / odchod a Jídelna příchod v časech 08:00 12:00

Družina - jde typicky o extra výtažek dětí, které vyžadují narozdíl od ostatních jiné časové oprávnění k přístupu do školy. pozn. Extra kategorie není úplně potřeba - osoby, které mají mít extra oprávnění lze ošetřit tak, že jim v jejich kartě přidělíme k jejich stávající roli (Studenti / Žáci) ještě roli Družina a tím pádem budou mít platná oprávnění obou rolí. Nicméně pokud bychom následně chtěli osoby nějak filtrovat, a nebo si chceme ponechat nastavení Role je 1:1 s Kategorií, je vhodné zařazení ve společné kategorii ponechat.

Kategorie / Role / Týdenní rozvrh Družina má narozdíl od Studenti/Žáci povolený vstup skrze identifikační zařízení Hlavní vchod a Jídelna v rozmezí 6:00 - 19:00, zatímco běžní studenti jej mají v rozmezí 7:00 - 15:00

Ostatní personál - typicky nepedagogičtí pracovníci, kteří mají přístup do všech oblastí ve stejně pojmenovaném Týdenním rozvrhu (06:00 - 19:00)

Studenti / žáci - obsahuje množinu všech žáků nebo studentů pokud je nepotřebujeme např. z důvodu oprávnění členit např. na 1. a 2. stupeň ZŠ - potom máme možnost je rozdělit do více kategorií. Pokud importujeme osoby např. ze Stravného 4, potom jim po aktualizaci zůstává kategorie nyní přidělená v Otvíráku a nepřepisuje se nastavením ze Stravného..

Tělocvična - trochu specifikum - typicky pokud pronajímáme tělocvičnu pro účely různých sportovních kroužků nebo oddílů, je fajn mít tyto Osoby oddělené kategorií. Nicméně vzhledem k tomu, že každá organizace = osoba (ano, každou organizaci stačí založit jen jako jednu osobu a jí přidávat neomezený počet čipů, které si mezi sebou rozdají) musí mít své specifické časové okno, je třeba pro ní vytvořit vhodně pojmenovaný (typicky dle pojmenování osoby) Týdenní rozvrh a Roli a roli poté osobě přidělit přímo v Osobě. Takto lze mít pod jednou kategorií Tělocvična více organizací a pomocí individuálně přidělených rolí (a jim Týdenních rozvrhů) všechny organizace. Typicky je nastaven přístup pouze do oblasti Tělocvična v daném týdenním rozvrhu

Uživatel programu - opět kategorie, kterou nemusí použít v případě, že je uživatel programu již zanesen v rámci jiné kategorie (např. Zaměstnanci, Ostatní personál), neboť mu stačí udělit oprávnění pomocí Role v jeho kartě. Samotnou kategorii využijeme spíše tam, kde bude uživatel programu externista. Tato kategorie a role má kromě jiného ještě zvýšená oprávnění k programu - řídí se nastavením sekce Moduly v Roli.

Zaměstnanci - mají oprávnění do všech Oblastí v rámci své stejně pojmenované role a Týdenního rozvrhu

ZZZX - slouží k "odložení" vyřazených osob, které nechceme z programu ihned smazat, ale chceme si k nim zachovat historii. Role "Každý" zajišťuje žádná oprávnění ke vstupu nebo v rámci programu.

ZZZZ - některé importy vyžadují aby všechny importované osoby měly právě jednu kategorii. Pokud toto ale toto není v rámci cizího systému nastavit, použije se tato kategorie pro hromadný import osob a jejich následné ruční rozřazení do již připravených správných kategorií, případně ji lze použít jako vzorovou..

V rámci kategorie lze např. nastavit, zda má program požadovat, aby byla vždy vyplněná položka Třída (např. u kategorie Studenti / Žáci je toto vhodné)

- Týdenní rozvrhy

Jsou defakto časová okna / časové zóny, které mi určují kdy smím či nesmí daným identifikačním zařízením (nebo do oblasti) projít.

- Role

určuje oprávnění dané kategorie nebo třídy nebo konkrétní osoby a to jednak z pohledu oprávnění přístupu Identifikačním zařízením (čtečkou) nebo do Oblasti, dále z hlediska viditelnosti a editovatelnosti ostatních osob v programu a v neposlední řadě ještě přístup k funkcím programu

- Aktivity

pokud zvládneme program nastavit tak, aby nám naplňoval představu přístupového systému, lze mu pomocí pár dalších modifikací přidat možnost evidovat docházku...

Stačí pro to zkontrolovat a případně doplnit Aktivity, které nám říkají, že průchod určitým id. zařízením (případně vstup do určité oblasti) neznamená je otevření dveří, ale zároveň program začne zaznamenávat, že tímto průchodem jsme začali aktivitu Práce. Případně pokud máme docházkový terminál, je možnost voleb těchto aktivit manuálně zadat na něm. Vždy platí pravidlo, že nová Aktivita automaticky ukončuje tu předchozí (nelze vykonávat více aktivit najednou) a pokud už nechce aktivovat, musíme projít zařízením, které má nastaveno že negeneruje žádnou aktivitu (typicky odchodové čtečky, aktivita Odchod na docházkovém terminálu).

Přehled docházky (resp. rozdělení do Aktivit) lze poté procházet v sekcích Provoz a Vyhodnocení

Výkazy

máme-li potřebu sledovat úvazky zaměstnanců a porovnávat je s evidovaným časem průchodů nebo aktivit, lze v kartě každé Osoby nastavit Úvazek (denní, týdenní a vyplnit týdenní rozvrh v rámci kterého má být odpracován) a program poté dokáže v sekci Vyhodnocení vyjet přednastavený Výkaz práce, případně podklady pro mzdu..


Jak začít po instalaci programu

Jak začít po instalaci programu

pozn. zákazník by měl mít předem promyšleno, jakým způsobem chce systém používat aby mu přinesl co největší užitek

alespoň nějaká takováto tabulka jako odrazový můstek bývá fajn

 |  | Role |  |  |  |  |  |  |
Řídící jednotky | Identifikační zařízení | Admin | Tělocvična | Ostatní personál | Žáci | Žáci s družinou | Zaměstnanci | Cizí /návštěvy | Cizí /jídelna
Hlavní vchod | příchod | Plný přístup |  | po-pá 6-19 | po-pá 7-13:30 | po-pá 6-16 | po-pá 6-18 | po-pá 8-12 |
 | odchod | Plný přístup |  | po-pá 6-19 | po-pá 12-14 | po-pá 12-16 | po-pá 6-18 | po-pá 8-12 |
Boční vchod | příchod | Plný přístup |  | po-pá 6-19 |  |  | po-pá 6-18 |  |
 | odchod | Plný přístup |  | po-pá 6-19 |  |  | po-pá 6-18 |  |
Jídelna | příchod | Plný přístup |  | po-pá 6-19 | po-pá 11-14 | po-pá 11-14 | po-pá 6-18 | po-pá 8-12 | po-pá 10:30-12
Tělocvična | příchod | Plný přístup | individuální | po-pá 6-19 |  |  | po-pá 6-18 |  |
 | odchod | Plný přístup | individuální | po-pá 6-19 |  |  | po-pá 6-18 |  |

Pokud je zadání hotové, lze pokračovat v konfiguraci programu v následujícím pořadí:

1. je doporučeno provést HW stránku věci - tj. osadit řídící jednotky a identifikační zařízení

2. vydefinovat si, která identifikační zařízení lze z přednastavených použít (typicky to bývá většinu minimálně Hlavní vchod), případně si nově hlášené jednotky výstižně pojmenovat - stejně tak i identifikační zařízení. Nakonec smazat nepotřebné Identifikační zařízení, Řídící jednotky (nově načteným řídícím jednotkám lze přes pravé tlačítko myši přidělit nastavení vzorové a tu posléze smazat). Pozor na to, že pokud budete chtít smazat řídící jednotku, nesmí tato být nastavena např. pro vzdálené otvírání (řízení)

3. promazat Kategorie (tato zase nesmí být použita např. v přednastavení pro importy ze školských systémů) , Týdenní rozvrhy a nakonec Role , vydefinovat si nové Týdenní rozvrhy , Kategorie a nakonec je spojit v Rolích

4. jako poslední provést import Osob a jejich doladění, vyzkoušení

5. Projít celé menu Ostatní , nastavit přístupová práva pro jednotlivé role, nastavení SMTP , kancelářských čteček

6. plánované akce - doplnit a případně upravit, z modulů odebrat vše, co obsluha nepotřebuje ke své práci.


Bázová data


Aktivity

Bázová data ››

Seznam aktivit, které je možné aplikovat na Osoby

Aktivity slouží k rozčlenění průchodů tak, aby bylo z hlediska docházky možné rozlišit druh přítomnosti resp. vykazované práce.


Popis aktivit a jejich použití

Bázová data ›› Aktivity ››

Aktivity

Aktivity slouží k rozčlenění průchodů tak, aby bylo z hlediska docházky možné rozlišit druh přítomnosti resp. vykazované práce.

Název aktivity

lze volně definovat, přejmenovávat

Mód přítomnosti

Práce - jsou všechny činnosti (pracovní cesty, pochůzky, nákupy apod.), které se mají ve výsledku resp. do Výkazu práce a Podkladů k mzdám započítat jako práce.

Nevykazovaná, std. zaokrouhlení prac. doby - z pohledu docházky se tato Aktivita nevykazuje (není vidět ve Výkazu práce, v Podkladech k mzdám), pracovní doba se nezaokrouhluje (vhodné např. pro přestávky na kouření)

Nevykazovaná, bez zaokrouhlování prac. doby - z pohledu docházky se tato Aktivita nevykazuje(není vidět ve Výkazu práce, v Podkladech k mzdám), pracovní doba se nezaokrouhluje (vhodné např. pro přestávky na oběd)

Vykazovaná jen použitá,včetně dnů std. zaokrouhlování prac. doby - z pohledu docházky se tato Aktivita vykazuje (Výkazy práce, Podklady k mzdám) jen v případě, že byla v měsíci alespoň 1x použita, pracovní doba se zaokrouhluje (vhodné např. pro dovolené, svátky)

Vykazovaná jen použitá, včetně dnů, bez zaokrouhlování prac. doby - z pohledu docházky se tato Aktivita vykazuje (Výkazy práce, Podklady k mzdám) jen v případě, že byla v měsíci alespoň 1x použita, pracovní doba se nezaokrouhluje (vhodné např. pro návštěvu lékaře)

Vykazovaná jen použitá,bez dnů std. zaokrouhlování prac. doby - z pohledu docházky se tato Aktivita vykazuje (Výkazy práce (bez dnů, jen hodiny)), Podklady k mzdám (bez dnů, jen hodiny)) jen v případě, že byla v měsíci alespoň 1x použita, pracovní doba se zaokrouhluje (vhodné např. pro dovolené, svátky)

Vykazovaná jen použitá, bez dnů, bez zaokrouhlování prac. doby - - z pohledu docházky se tato Aktivita vykazuje (Výkazy práce (včetně dní a hodin), Podklady k mzdám (včetně dní a hodin)) jen v případě, že byla v měsíci alespoň 1x použita, pracovní doba se nezaokrouhluje (vhodné např. pro návštěvu lékaře)

Vykazovaná vždy,včetně dnů std. zaokrouhlování prac. doby - dtto jako varianta výše, jen na výkazu vyjede i pokud nebyla v měsíci použitá (aplikuje se v případě exportů do externích systémů, kdy je třeba dodržet pevnou strukturu souboru)

Vykazovaná vždy,včetně dnů bez zaokrouhlování prac. doby - dtto jako varianta výše, jen na výkazu vyjede i pokud nebyla v měsíci použitá (aplikuje se v případě exportů do externích systémů, kdy je třeba dodržet pevnou strukturu souboru)

Vykazovaná vždy, bez dnů std. zaokrouhlování prac. doby - dtto viz výše

Vykazovaná vždy, bez dnů, bez zaokrouhlování prac. doby - dtto viz výše

Barva

slouží k rozlišení aktivity v grafických přehledech

Použití pro

průchody = aktivita je generovaná na základě průchodu čtečkou nebo volbou na docházkovém terminálu

blokové prezence = aktivita je do systému zanesena ručně uživatelem programu v sekcích Provoz (Nástěnka) nebo Přehledy (např. Měsíční přehled (graf))

svátky = aktivita vyčleněná pro svátky - doporučeno neměnit

Automaticky ukončovat při konci pracovní doby dle úvazku = u některých aktivit je žádoucí, aby se automaticky ukončily pokud uplyne doba úvazku - například pokud zaměstnanec odchází během pracovní doby k lékaři a nechceme aby nám Aktivita pokračovala donekonečna. K ukončení aktivity dojde v okamžiku, kdy zaměstnanec dosáhne počtu hodin daných úvazkem od prvního příchodu.

Identifikační zařízení

- seznam jednotlivých identifikačních zařízení, které danou aktivitu používají. Samotnou Aktivitu lze přiřadit přímo v každém identifikačním zařízení.

Role

- role, které mají danou aktivitu povolenou a možnosti jim aktivitu povolit či zakázat. Například na docházkovém terminálu je žádoucí, aby Studenti / žáci neměli přístupné aktivity OČR, Nemoc atd. určené zaměstnancům.

Použití

- přehled použití Aktivit v průchodech


Role

Bázová data ››

Role

je nastavení oprávnění přístupů, přístupových práv a funkcím programu


Role

Bázová data ›› Role ››

Role

pomocí rolí se nastavují oprávnění jednak k povolení průchodů, druhak oprávnění přístupu k datům v programu

Název

pojmenování role

Každý

při zaškrtnutí bude mít tuto roli každá osoba zadaná v programu

Správa terminálů

určuje zda vybraná role má oprávnění ke spravování docházkových terminálů

Řízení přístupu k k oblasti

Dle oblastí = přístup k čtečkám lze zjednodušeně řídit přímo jak přístup do určité oblasti (která typicky obsahuje více identifikačních zařízení). Pokud je vybráno, v záložkách se objeví záložka Oblasti.

Dle identifikačních zařízení = přístup se řídí přímo přes jednotlivá identifikační zařízení, v případě vybrání této volby se záložka Oblasti změní na záložku Zařízení

Neřídí přístup k prostředí = role resp. její členové nemají přístup k identifikačním zařízením

Lidé

přehled osob, s vyznačením těch, které jsou členy vybrané role. Zaškrtnutím příslušné kolonky lze osobu do dané role přidat.

Kategorie

přehled kategorií, které mají danou roli přidělenou, případně možnost jí přidělit

Třídy

přehled tříd, které mají vybranou roli nebo možnost přiřazení tříd k roli

Aktivity

Výběr aktivit, které daná role může používat. Obráceně lze sledovat v konkrétní aktivitě zda jí tato role má přístupnou.

Vzdálené otevírání

role má možnost vzdáleně z programu otevírat jednotlivé dveře.

Oblasti / Identifikační zařízení

zde definujeme zda vybraná role má přístup do konkrétní oblasti s možnostmi:

Plný přístup = přístup do zadané oblasti bez časového omezení

Žádný přístup = daná role nemá do oblasti žádný přístup

V daném týdenním rozvrhu -> následuje výběr z Týdenního rozvrhu, v rámci kterého je povolen přístup do oblasti.

Jen v přítomnosti člena role (dostupné jen pokud řídíme přístup dle Oblasti).. -> u ponížené role lze nastavit, že přístup do dané Oblasti (např. učebna a Studenti / žáci) je možný pouze pokud je v dané oblasti přítomný člen nadřazené role (např. Zaměstnanci)

Provázané role

povolení zobrazení dat (např. Osob) a jejich editace

při následujícím nastavení má role Zaměstnanci povolení vidět a editovat pouze roli Studenti /žáci

Výsledkem je zobrazení pouze vybraných osob v tabulce Osoby

Master role pro

pokud jsme si na záložce Oblasti zadali, že přístup je možný jen v případě přítomnosti člena jiné role (viz nastavení),

potom bude na záložce Master role zobrazen přehled pro které role je naše otevřená jako Master

Přehled členů

zde je zobrazen přehled členů editované role - jen přehled bez možnosti editace


Kategorie

Bázová data ››

Kategorie (vyšší členění osob)

slouží k rozřazení osob se společnými vlastnostmi do vyšších celků


Popis kategorie

Bázová data ›› Kategorie ››

Kategorie a její položky

Název

pojmenování kategorie

Externí ID

není použito

Zaokrouhlování pracovní doby

výběr z dostupných zaokrouhlování směn

Třída povinné

pro určité kategorie může být povinné hlídat vyplněnost položky Třídy (typicky u studentů / žáků)

Lidé

přehled členů dané kategorie s možností přesunu osoby do aktuální kategorie

Role

přiřazení konkrétní role celé kategorii resp. jejím členům


Třídy

Bázová data ››

Třídy (podrobnější dělení osob)


Třídy

Bázová data ›› Třídy ››

Třídy (podrobnější dělení osob)

Název

Lidé

přehled osob, s vyznačením těch, které jsou členy vybrané třídy. Zaškrtnutím příslušné kolonky lze osobu do dané třídy přidat.

Role

přehled rolí, které má vybraná třída nebo její členové s možností přiřazení.


Osoby

Bázová data ››

Osoby

    1. tlačítko pro založení nové osoby
    2. tl. pro opravu údajů v kartě osoby
    3. tl. pro smazání osoby z programu
    4. tisk resp. výpis tabulky osob s možností exportu např. do XLS
    5. otevření tabulky je statické, tj. pro načtení aktuálních změn je třeba pohled aktualizovat
    6. vyvolá čtení z lokální čtečky čipů a po přiložení čipu vyhledá osobu s daným čipem (pokud existuje)
    7. slouží ke sloučení více osob v případě, že je po importu z cizího systému osoba zadána duplicitně (např. ve ŠkolaOnLine má zaměstnanec více úvazků).
    8. hromadné změny nad tabulkou osob - např. hromadné zadání úvazku, změna kategorie nebo třídy


Založení nové osoby

Bázová data ›› Osoby ››

Založení nové osoby

Osobní číslo (volitelná položka, vhodné vyplnit v případě vedení docházky)

typicky osobní číslo v mzdovém systému

Jméno

Příjmení

Kategorie

výběr z předdefinovaného seznamu vyššího členění osob

Třída

výběr z předdefinovaného seznamu nižšího členění osob – dle nastavení kategorie může být povinná položka (např. pro děti)

Přihlášení do systému

pokud je zaškrtnuto a vyplněno, má osoba možnost přihlášení do programu spolu se zobrazením uvítacího textu

Zaokrouhlení pracovní doby

výběr z předdefinovaných možností v rámci kategorie nebo individuální výběr

Upozornění při průchodech

pokud je zaškrtnuto, dojde při průchodu viditelné osoby (seznam je na záložce Přístup / Osoby) k notifikaci skrz Windows upozornění. Analogicky platí i pro Neznámé čipy.

Význam jednotlivých záložek je dále pod obrázkem

Přístupové klíče

seznam přístupových čipů/karet a možnost práce s nimi. V programu může mít každá osoba teoreticky neomezený počet přístupových klíčů (čipů / karet). Tlačítkem Přidat klíče je možné osobě přiřadit nové číslo čipu spolu s poznámkou. Program automaticky doplní datum a čas přiřazení čipu do programu. Kolonka Název slouží pro pojmenování konkrétního čipu a je povinná (pokud má osoba více čipů pro přístup např. aby dítě mohli vyzvedávat rodiče, je fajn si čipy pojmenovat např "Otec", "Maminka" atd.)

Přidat klíč lze kromě možnosti načtení pomocí kancelářské čtečky k tomu určené (toto je jediný správný způsob) i přes Přidat existující klíč, kdy se otevře seznam čipů přečtených všemi zařízeními a my zvolíme ten aktuální pro naší osobu. Nevýhodou tohoto řešení je, že přístupové čtečky nepřečtou celé číslo čipu a byť bude tento čip v přístupovém systému fungovat, v samotné aplikaci se bude objevovat místo čísla čipu hláška "Nedostatek dat".

Pro každý čip lze v případě sledování docházky vyplnit úvazek, který se daného čipu týká (např. pokud je jeden čip používán pro úvazek plný, druhý pro částečný), typicky se nepoužije.

Role

přidělená oprávnění osobě - typicky se přebírá z kategorie, ale je možné např. uživateli programu přidat kromě role Zaměstnanec ještě roli Uživatel programu

Dovolené

umožňuje definovat období, po které čerpá dovolenou. Tato musí být v některých případech schválena.

Úvazky

zde je možnost definovat úvazky osoby v návaznosti na evidenci pracovní doby, viz. samostatné téma

E-mailová upozornění

zde je možnost nastavit upozornění, která budou chodit osobě. Po vyplnění emailu je na výběr

Při pozdním příchodu - je vázáno na týdenní rozvrhy..

Při průchodů zařízením - při průchodu vybraným zařízením přijde emailové upozornění - četnost lze regulovat volbou rozestupu tak, aby upozornění nechodila příliš často

Výkaz práce - pokud má osoba zadaný úvazek, lze jí na konci měsíce v rámci hromadného odeslání výkazů na uvedený email zaslat měsíční výkaz

Externí ID

pro načítání seznamu osob z externích systémů (Stravné, ŠkolaOnLine, EdooKit, EduPage) má každá osoba své jedinečné (primární) ID, pod kterým je vedena v obou systémech.

Pokud je např. v systému ŠkolaOnLine vedena s více úvazky, pak by se do naší aplikace naimportovala vícekrát, což je pro nás nepotřebné a je možnost více osob sloučit do jedné pomocí volby v menu tabulky Osoby.

Přehledy

Přístup

přehled přístupu k jednotlivým identifikačním zařízením, modulům, aktivitám a podřízeným osobám. Slouží pro kontrolu kam má osoba přístup, v jaké je roli atd.

Průchody

seznam průchodů vybrané osoby jednotlivým identifikačními zařízeními


Úvazky

Bázová data ›› Osoby ››

Úvazky

Název - vlastní pojmenování úvazku a to např. jméno a denní odpracovaná doba

Týdenní úvazek - přednastavený programem na 40 hodin

Denní úvazek - nutné vyplnit - tyto hodiny program potřebuje pro výpočty do Výkazů práce

Začátek - od kdy tento úvazek platí, typicky vyplňujeme první den aktuálního měsíce

Konec - pokud by se úvazek měnil, je třeba jej kvůli historii zachovat a vyplnit typicky poslední den platnosti úvazku

Podklady ke mzdám - v jaké formě se má zobrazit na stejně pojmenované sestavě v sekci Vyhodnocení

Hodinová sazba - nepovinná položka - pokud bychom chtěli na sestavě Podklady ke mzdám vyčíslit místo hodin nebo dní pevnou sazbu

Měsíční sazba - nepovinná položka - viz předchozí bod

Rozvrh směn - nutné vyplnit - typicky vyplníme Od prvního dne aktuálního měsíce a týdenní rozvrh , ve kterém má být práce vykonávána


Prostředí


Oblasti

Prostředí ››

Oblasti


Oblasti a jejich význam

Prostředí ›› Oblasti ››

Oblasti

jsou podrobnějším dělením zón (které až na výjimky, kdy máme více odloučených pracovišť nepoužíváme) na menší celky - typicky budovy / pavilony (ale lze použít i pro třídy pokud do nich budeme definovat přístupy)

Název

Název prostor

Zóna

nadřazená položka - pro naše účely bude stačit předdefinovaná zóna "Celá škola"

Barva

volitelná položka

Popis položek:

Role

přehled rolí, které mají do dané oblasti přístup. Nastavení přístupu se provádí v rolích

Identifikační zařízení

seznam identifikačních zařízení, která typicky do této oblasti vedou

Právě přítomní

seznam osob, které se právě nachází ve vybrané oblasti


Řídící jednotky

Prostředí ››

Řídící jednotky


Řídící jednotky

Prostředí ›› Řídící jednotky ››

Řídící jednotky

se starají o komunikaci mezi identifikačním zařízením (čtečkou) a programem, obsahují relé které je schopné dát impuls k otevření dveří a v případě výpadku elektriky obsahují offline verzi povolení vstupu.

Název

název řídící jednotky typicky odráží její umístění

Externí ID

nepovinná položka - slouží k identifikaci v případě exportu průchodů do aplikace třetí strany

Sériové číslo

je jedinečná needitovatelná položka, která je dána výrobcem a je složená 4(číslo přidělené VIS)x-xx-xx(zákaznické číslo zarovnané doprava)-xx(pořadové číslo v rámci zákazníka).

40-00-00-01 je tedy řídící jednotka od fy. VIS, zákazníka s číslem 00000 a pořadovým číslem 01

Identifikační zařízení

seznam už pojmenovaných čteček připojených k této řídící jednotce

Zasílat absenci SD na email

pokud je zaškrtnuto a řídící jednotka zjistí výpadek integrované SD karty (díky ní systém funguje i pokud vypadne spojení mezi řídící jednotkou a serverem, kde běží služba), zašle na vyplněný email upozornění

Hlásit chybějící spojení dodavateli softwaru - dnes již nefunkční vlastnost

Vzdálené řízení

je nutné vyplnit rolím, jejíž členové mají mít možnost ovládat po přihlášení do programu na dálku "odbzučení"

Restarty zařízení

protokol se záznamy o restartech řídící jednotky

Onboard nastavení

Nastavení řídící jednotky - pokud je nastavena první položka na IP adresu serveru kde běží služba, lze si po stisknutí tlačítka "Načíst ze zařízení" nechat zobrazit informace o konfiguraci řídící jednotky a případně je editovat:

IP adresa serveru = nastavení proti jaké IP adrese má řídící jednotka komunikovat - vždy je to IP adresa, kde běží služba pro komunikaci s řídící jednotkami, nikoliv kde je spuštěný program

Port serveru = port na kterém služba komunikuje - standardně přednastavený a není až na výjimky žádoucí měnit

Reverzní zámek = určení zda relé, které je v řídící jednotce je trvale sepnuté (reverzní režim a zámek) nebo rozepnuté (typický režim) a při impulsu z programu a nebo průchodem identifikačním zařízením program program na stanovenou dobu relé (de)aktivuje.

Hlavní vchod - odchod [ms] určuje délku aktivace relé v milisekundách - standardně přednastaveny 2s - pro konkrétní identifikační zařízení

Hlavní vchod - příchod [ms] určuje délku aktivace relé v milisekundách - standardně přednastaveny 2s - pro konkrétní identifikační zařízení

Protokol stavu dveří

neaktuální položka - v případě, že je k dveřím připojený senzor stavu dveří (dveřní kontakt) dokáže program zaznamenávat kdy byly dveře otevřené

Protokol výjimek

neaktuální položka


Identifikační zařízení

Prostředí ››

Identifikační zařízení

jinak řečeno jednotlivé dveřní čtečky


Identifikační zařízení

Prostředí ›› Identifikační zařízení ››

Identifikační zařízení (čtečky)

Název

název čtečky v systému - doporučeno je pojmenovávat Název řídící jednotky + označení strany průchodu

Řídící jednotka

ke které je identifikační zařízení fyzicky připojeno

Skupina zařízení

vybíráme z nám jediné dostupné varianty

Cílová oblast

v případě příchodu vybíráme oblast, kam skrze čtečku vcházíme, v případě odchodové strany ponecháme prázdné

Technologie

pevná položka

Povolené aktivity

vybíráme Aktivitu(y), která se při povoleném průchodu čtečkou začne generovat. Pokud systém nepoužíváme pro účely evidence, ponecháme prázdné, v opačném případě se osobám resp. dle jim přiřazené role začne generovat Aktivita. V našem případě role Studenti / žáci nemá povolené žádné Aktivity, takže při průchodu zařízením je zaznamenán jen průchod bez další návazností, zatímco pokud zařízením projde zaměstnanec, začne se mu do docházky generovat Aktivita "Práce", případně po překročení nastavené doby obědová pauza.

Aktivity

viz výše

Role

přehled rolí a jejich oprávnění k průchodu

Průchody

jmenovitý přehled průchodů aktuálním zařízením


Terminály

Prostředí ››

Terminály (docházkové)


Docházkový terminál

Prostředí ›› Terminály ››

Docházkový terminál

Zkratka

musí být jednoznačná a slouží jako parametr pro volání docházkového dialogu z Windows

Název

popis terminálu, případně jeho umístění

Externí ID

pokud mají být průchody realizované terminálem zanášeny do elektronických třídních knih, musí být vyplněné

Administrace pomocí PIN

zabezpečuje, že nelze ukončit dialog na docházkovém terminálu neoprávněné osobě

Font

jakým budou zobrazeny volby na terminálu

Další možnosti - barva pozadí

podbarvení pozadí

Další možnosti - barva písma

barva ostatních položek na terminálu (kromě tlačítek)

Tlačítka vlevo / vpravo

tlačítka na terminálu pro prioritní volby jsou rozdělena vertikálně na dvě poloviny

Tlačítka další

pokud přeroste seznam Aktivit na terminálu přes počet základních pozic, další Aktivity budou dostupné na samostatné obrazovce vyvolané tlačítkem Další

Popiska - tlačítka - text zobrazený na tlačítku (může být různý od Aktivity)

Barva pozadí tlačítka

Barva písma

Cílová oblast - pokud tlačítko označuje příchod, je vhodné vybrat cílovou oblast

Aktivity - vybrat tu, která se začne generovat aplikací tlačítka

Zvýraznit od / do - typicky je žádoucí, aby od ráno do např. 10:00 bylo tlačítko pro příchod zvýrazněno a aktivuje se pouhým přiložením čipu / karty, od 10:00 se naopak zvýrazní a "předaktivuje" tlačítko pro odchod

Okraj při zvýraznění je barva okraje, které tlačítko zvýrazní

šipky slouží k seřazení tlačítek na terminálu v rámci sloupce..


Čas


Týdenní rozvrhy

Čas ››

Týdenní rozvrhy


a jejich význam

Čas ›› Týdenní rozvrhy ››

Týdenní rozvrhy

slouží:

a) v návaznosti na roli jako možná definice časového okna ve kterém je povolené projít identifikačním zařízením

b) v návaznosti na docházku pro definici denního úvazku

Název

doporučeno je pojmenovat rozvrh podle budoucí (role, kategorie, třídy nebo osoby), časového okna a pokud evidujeme docházku, tak přidat i úvazek

Plovoucí

pokud je zaškrtnuto, je možné definovat začátek od - do a stejně tak i konec od - do. Vhodné pokud rozvrh slouží zároveň pro úvazky u zaměstnanců, jinak je možné použít obyčejný

Max hodin

je součtem maximální

Celkem hodin

je součet zadaných časových oken

je součtem všech zadaných úvazků

Vložení nového časového okna

Pokud vydefinujeme první časové okno s případným úvazkem, potom se při kliknutí na Vložit přednastaví ty samé hodnoty pro další den v týdnu.

pomocí Od - Do definujeme časové okno přístupu a zároveň (nezávisle na předchozích hodnotách) hodnotu denního úvazku.

V případě, že definujeme složitější časová okna napři pro žáky (kde naopak neevidujeme úvazky), lze ruční přepsáním definice vložit do jednoho dne více časových oken.

např.:

Je však třeba pamatovat na to, že pokud je požadavkem řídit zvlášť příchod a odchod v různých časových oknech, je třeba udělat samostatný týdenní rozvrh pro příchod a pro odchod.

Kategorie prázdnin

říká, že v případě že nastane zvolené aktivní období, platí výjimka pro přístup definovaná v Prázdninách

Použití = přehled pro koho je daný týdenní rozvrh platný resp. komu je přiřazený..


Zaokrouhlování směn

Čas ››

Zaokrouhlování směn


Zaokrouhlování směn

Čas ›› Zaokrouhlování směn ››

Zaokrouhlování směn

používá se jen v případě evidence docházky a potřeby jejího zaokrouhlování, ale minimálně jedno zaokrouhlení musí být definované.

Název

pojmenování systému zaokrouhlení

Příchod navíc

umožňuje nadefinovat čas navíc, který se přičte k času příchodu (použije se např. v případě, že je identifikační zařízení (čtečka) na hranici vstupu do areálu a víme, že samotná vykazovaná práce začne až za určitý časový interval - až se osoba dostane na své pracoviště. Příklad - pokud se osoba identifikuje u vstupu do areálu (třeba v 6:30), ale cesta na samotné pracoviště trvá 2 minuty, systém začne evidovat pracovní dobu až od 6:32

Odchod navíc

opačný postup než u příchodu - tzn. pokud se osoba při odchodu identifikuje až na výstupu z areálu v 14:35, systém jí při nastavení 2 minut odečte zaznamená čas ukončení Aktivity (práce) ve 14:32

Příchod zaokrouhlení

typicky příchod v 6:31:25 budeme chtít pro účely docházky zaokrouhlit na 6:32 (zaokrouhluje se vždy nahoru). Vybírat můžeme z přednastavených hodnot.

Příchod zaokrouhlit jen v nepřítomnosti delší než

upravuje předchozí podmínku, kdy říkáme, že pokud je mezi odchodem a příchodem nějaký časový interval, který je menší než nastavená hodnota, potom výše uvedené zaokrouhlení neaplikujeme (odskočíme si z areálu jen něco vyzvednout, někoho doprovodit apod.)

Odchod zaokrouhlení

opačný postup než při příchodu, zaokrouhluje se vždy dolu

Odchod zaokrouhlit jen při nepřítomnosti delší než

dtto jako příchod

Po odpracování "06:00:00" vytvořit pauzu v délce "00:30:00" s aktivitou "Oběd" slouží k automatickému generování obědové pauzy. Pozor - pauza se vygeneruje jen v případě, že aktivita Práce není průběžně přerušována.

Transformace aktivit

použijeme např. v případě, že si osoba při odchodu zapomněla toto označit na terminálu nebo čtečce. Nyní je jediná možnost změny aktivity definována na půlnoc a zároveň bez odchodu, původní a novou aktivitu je možné vybrat. Nová aktivita potom pokračuje místo původní a v následné editaci docházky je díky odlišení vidět zapomnětlivce a nutnost ruční úpravy jejich docházky.

V případě kdy máme např. noční směny, lze využít transformaci aktivit k jejich vykázání.

1. je třeba vytvořit Aktivitu Noční (v režimu Práce)

2. je třeba vytvořit fiktivní Týdenní rozvrh, který bude od pondělí do neděle a jenž bude obsahovat časová okna od 22:00 - 06:00

3. Vytvoříme novou transformaci aktivit (musí být v samostatném Zaokrouhlení směn a které použijeme jen pro pracovníky s noční), kdy programu řekneme, že původní aktivita Práce se v týdenním rozvrhu Noční změní na aktivitu Noční.


Svátky

Čas ››

Svátky


Svátky

Čas ›› Svátky ››

Seznam svátků zadaných v programu

slouží primárně pro evidenci docházky a nemá vliv na přístup.

Import a svátků a jeho nastavení je společný s funkcí Import svátků/prázdnin

Název svátku

Datum

Část dne

typicky platí celý den

Aktivita

vyhrazená pro svátek


Prázdniny

Čas ››

Prázdniny


Prázdniny

Čas ›› Prázdniny ››

Seznam prázdnin stažených do programu

na rozdíl od svátků neslouží pro potřeby evidence docházky, ale pro řízení přístupu - jejich typickým využitím je zamezení přístupu např. studentům / žákům (případně jiným kategoriím) do prostor školy o prázdninách nebo v jiném definovaném období.

Pro správnou funkčnost je ještě třeba nastavit v Týdenním rozvrhu platným pro danou kategorii Studenti / žáci (popřípadě Družina), že jsou u nich kategorie prázdnin Aktivní.

Kategorie - výběr ze seznamu předdefinovaných kategorií (který lze editovat v menu Čas / Kategorie prázdnin - ve výchozím stavu skryté)

Název - pojmenování prázdnin

Datum od - do je den / období trvání prázdnin.

Nastavení pro import svátků/prázdnin z internetu je popsáno v menu Addiny -> Import svátků/prázdnin

Ruční zadání mimořádného období

Chceme-li nastavit nějaké mimořádné období, během kterého chceme zamezit přístupu studentů / žáků do oblasti školy, zvolíme v horním menu tabulky Prázdnin Nový a jako kategorii vybereme např. Mimořádné, do názvu si zadáme důvod omezení a vyplníme datum / období, během něhož má omezení platit.

a výsledek by mohl vypadat nějak takto:


Ostatní


Globální nastavení

Ostatní ››

Globální nastavení


a jeho položky

Ostatní ›› Globální nastavení ››

Globální nastavení

SMTP nastavení

slouží k nastavení SMTP serveru uživatele - bez tohoto není možné aby program odesílal emailové notifikace (nastavení v programu slouží jako funkční příklad). Nastavení lze otestovat pomocí tlačítka - program vygeneruje a odešle email s potvrzením funkčnosti. Na serverech pozor na nastavení restrikcí ve firewallu, případně různých politik zakazují cizí SMTP.

Signalizace zařízení

neaktuální položka

Ostatní

Složka záloh DB - je cesta (většinou definovaná již při instalaci) kam program ukládá zálohy SQL databáze. Nastavení lze otestovat v sekci Údržba -> Databáze

Podpora Wiegand26 - mělo by být automaticky zatržené v případě detekce použití starších čteček Sebury, které neumějí více než Wiegand 26

3rd party přístup

slouží k nastavení přístupových údajů, skrze které bude komunikovat případné webové rozhraní, komunikace ze serveru www.strava.cz nebo mobilní aplikace. Komunikace probíhá skrze port 43538

Notifikace

zde lze nastavit emailovou notifikaci v případě, že některá z řídících jednotek z jakéhokoliv důvodu přestane komunikovat se serverem. Volitelným parametrem je výběr konkrétní řídící jednotky, timeout komunikace a emailová adresa kam se upozornění pošle. V případě že komunikace vypadne, odešle se zpráva pouze 1x a poté znovu opět při další výpadku


Moduly

Ostatní ››

Moduly


aneb co oko nevidí

Ostatní ›› Moduly ››

Moduly

program je tvořen mnoha moduly, přičemž ne každý typ uživatele by měl mít možnost přístupu k určité části programu.

Přístup k modulům se definuje na úrovni rolí, přičemž platí, že každá osoba může být členem více rolí - povolené je tím pádem to co má povolené průnik rolí, jejíž je osoba členem.

Nejčastěji můžeme modul roli jen povolit nebo zakázat, v některých případech nastavit jen pro čtení a u vybraných modulů ještě aplikovat viditelnost pouze některých položek modulu - viz obrázek.


Uživatelská nastavení

Ostatní ››

Uživatelská nastavení


Uživatelská nastavení

Ostatní ›› Uživatelská nastavení ››

Uživatelská nastavení

se definuje a aplikuje na právě přihlášeného uživatele.

Oblíbené

pokud je zaškrtnuto, objeví se v levém horním rohu stejnojmenná ikona a po kliknutí na ní se zobrazí seznam zaškrtnutých položek

Vzdálené ovládání dveří

v případě zaškrtnutí se do Oblíbených přidají tlačítka, která po kliknutí "odbzučí" dle doby definovatelné vedle pojmenované řídící jednotky

Různé

"Zavřít místo minimalizovat" nezaškrtnuté zajistí, že po kliknutí na křížek se program minimalizuje do tray místo definitivního ukončení programu

Zobrazení čipů - volba formátu zobrazení čipu ve formátu VIS a nebo v hexa tvaru. Ve výchozím stavu je VIS formát kvůli možnosti importu z programu Stravné a možnosti ručního porovnání čísel čipů (karet) v obou systémech


Údržba

Ostatní ››

Údržba


Údržba

Ostatní ›› Údržba ››

Údržba

zobrazuje přehled řídících jednotek a zálohování.

Zařízení:

zobrazuje stav všech řídících jednotek, její IP adresu a port pomocí kterého komunikuje se serverem

podstatná je časová položka Poslední zpráva, kde lze ověřit kdy naposledy řídící jednotka zakomunikovala se službou. Standardně bez přiložení čipu k identifikačnímu se řídící jednotka hlásí 1x za 30s

na obrázku je vidět stav, kdy SD není přítomna a nebo je poškozená

Stáhnout vše - provede ručně stažení všech dat zapsaných v řídící jednotce, která se tam nashromáždila během výpadku komunikace se serverem

Synchronizovat vše - provede ruční synchronizaci dat mezi aplikací a řídící jednotkou aby ta mohla fungovat v případě výpadku spojení mezi nimi

Databáze

přehled všech vytvořených záloh s možností obnovy a nebo provedení ruční zálohy. Ke každé ruční záloze je možnost zadat ručně popisek.


Plánované akce

Ostatní ››

Plánované akce

V programu jsou připravené akce, které lze programu naplánovat tak, aby je program prováděl automaticky v zadaný čas nebo intervalech.


Záloha databáze

Ostatní ›› Plánované akce ››

Záloha databáze

Název akce

volitelné pojmenování

Akce:

Záloha databáze - umožňuje automatické zálohování v zadaný čas - typicky třeba 1x denně v čas, kdy program nemá spuštěný obsluha.

Parametrem je cesta kam se má zálohovat (nevyplněno = použije se cesta z Globálního nastavení) a název souboru - např. Záloha [dd] [MM] [yyyy].bak vytvoří soubor se zálohou pojmenovaný "Záloha 2020 01 01"


Aktualizace DB řídících jednotek

Ostatní ›› Plánované akce ››

Aktualizace DB řídících jednotek

Název akce

volitelné pojmenování

Akce:

Aktualizace DB řídících jednotek - umožňuje automaticky synchronizovat přístupy v programu s řídícími jednotkami tak, aby řídící mohla fungovat i při ztrátě spojení se serverem.

Aktivace - je doporučeno např. 1x denně v méně exponovaný čas

tato akce nemá žádné parametry


Stravné 4 - import osob

Ostatní ›› Plánované akce ››

Stravné 4 - import osob

importuje změny u Osob z programu Stravné VIS

Název akce

volitelné pojmenování

Akce:

Stravné 4 - import osob - umožňuje automatické načtení změn z programu Stravné 4 (konkrétně exportního souboru databart.dbf, kam program Stravné automaticky ukládá všechny změny u strávníků (opravy, výměny čipů, blokace, založení nové osoby).

Nastavení parametrů akce se přebírá z Addinu Stravné 4 - import osob

Protože import ze souboru provádí služba aplikace, která běží pod lokálním účtem CsBehereAdmin, je téměř nutností aby byl načítaný soubor na lokálním disku -> tím zajistíme, že bude mít služba oprávnění z něj číst a zapisovat do něj. Do složky s importním souborem musí mít přístup uživatel CsBeHereAdmin, pod kterým služba standardně běží.

Pokud je nezbytné nechat soubor na jiném stroji, je nutné aby se služba CsBeHere byl spuštěna pod uživatelem, který má úplná oprávnění k práci se souborem a zároveň na lokálním stroji oprávnění k SQL a lokálním složkám.


Škola Online - import a export

Ostatní ›› Plánované akce ››

Škola OnLine

import osob a export průchodů

Název akce

volitelné pojmenování

Akce:

Škola online - import osob umožňuje automatické načtení seznamu všech osob ze systému Škola OnLine

Parametry tato akce nemá resp. jsou přebírány ze samotné akce Integrace Škola Online v hlavním podmenu Addiny

Škola online - export průchodů umožňuje automatické odeslání seznamu průchodů do třídní knihy systému Škola OnLine

Parametry tato akce nemá resp. jsou přebírány ze samotné akce Integrace Škola Online v hlavním podmenu Addiny


Synchronizace osob Bakaláři

Ostatní ›› Plánované akce ››

Synchronizace osob Bakaláři

importuje změny u osob ze systému Bakaláři skrze datový konektor

Název akce

volitelné pojmenování

Akce:

Synchronizace osob Bakaláři - umožňuje automatické načtení seznamu osob ze systému Bakaláři skrz jejich datový konektor

Parametry - tato akce má jen na výběr co se má stát při importu osoby, která nemá zadanou třídu (doporučeno "Založit třídu") resp. jsou přebírány ze samotné akce Integrace systému Bakaláři v hlavním podmenu Addiny


EdooKit - import a export

Ostatní ›› Plánované akce ››

EdooKit - import a export

importuje změny u Osob ze systému EdooKit

Název akce

volitelné pojmenování

Akce:

EdooKit - import osob - umožňuje automatické seznamu (aktivních) osob ze systému EdooKit

Parametry tato akce nemá resp. jsou přebírány ze samotné akce Edookit nastavení v hlavním podmenu Addiny

EdooKit - export průchodů - umožňuje automatický export průchodů do třídní knihy v systému EdooKit

Parametry tato akce nemá resp. jsou přebírány ze samotné akce Edookit nastavení v hlavním podmenu Addiny


Aktualizace svátků a prázdnin

Ostatní ›› Plánované akce ››

Aktualizace svátků a prázdniny

automaticky importuje dostupné svátky a prázdniny do programu

Máme-li nastavený import svátků a prázdnin , můžeme jej nastavit tak, aby si program další svátky a prázdniny importoval automaticky.

Název - libovolné pojmenování

Akce - zde je třeba vybrat akci pro Import svátků/prázdnin

Popis - nepovinná položka

Aktivační událost - doporučena je kontrola 1x měsíčně v libovolný čas (ale mimo časový rozsah ostatních plánovaných akcí).


Nastavení počítače

Ostatní ››

Nastavení počítače

v současné době obsahuje jen nastavení pro čtečku čipů / karet v kanceláři

z důvodu užívání čteček závislých na COM portu PC, které mohou být na každém PC jinak přiřazené je toto nastavení ukládání vždy pro konkrétní PC

Žádná :-)

Klasická čtečka (všechny porty) - v tomto nastavení program při požadavku na přečtení čipu projde všechny porty PC a čeká co mu OS vrátí

VIS čtečka na portu - klasická čtečka čipů EC (EM), která má po instalaci vlastní virtuální COM port

VIS čtečka (klávesnicová) - malá čtečka do USB, která čte číslo čipu do klávesnicového bufferu


Nastavení počítače

Ostatní ›› Nastavení počítače ››

Uživatelská nastavení

se definuje a aplikuje na právě přihlášeného uživatele.

Oblíbené

pokud je zaškrtnuto, objeví se v levém horním rohu stejnojmenná ikona a po kliknutí na ní se zobrazí seznam zaškrtnutých položek

Vzdálené ovládání dveří

v případě zaškrtnutí se do Oblíbených přidají tlačítka, která po kliknutí "odbzučí" dle doby definovatelné vedle pojmenované řídící jednotky

Různé

"Zavřít místo minimalizovat" nezaškrtnuté zajistí, že po kliknutí na křížek se program minimalizuje do tray místo definitivního ukončení programu

Zobrazení čipů - volba formátu zobrazení čipu ve formátu VIS a nebo v hexa tvaru. Ve výchozím stavu je VIS formát kvůli možnosti importu z programu Stravné a možnosti ručního porovnání čísel čipů (karet) v obou systémech


Provoz


Nástěnka

Provoz ››

Nástěnka

slouží k přehledu o docházce a její případné editaci aktuálně přihlášenému uživateli

Zobrazuje souhrn prezence s možností editace v okně Měsíční prezence s volbami pod pravým tlačítkem myši.


Vyhodnocení


Přehledy

Vyhodnocení ››


Denní přehled

Vyhodnocení ›› Přehledy ››

Denní přehled

umožňuje zobrazit docházku osob v rámci vybraného data s výběrem osob v rámci kategorií spolu s legendou.

Editaci je možné provádět u vybrané osoby přímo v tabulce s možnostmi pod pravým tlačítkem myši


Měsíční přehled (Graf)

Vyhodnocení ›› Přehledy ››

Měsíční přehled (Graf)

umožňuje zobrazit docházku osob v rámci vybraného měsíce s výběrem osob v rámci kategorií spolu s legendou.

Editaci je možné provádět u vybrané osoby přímo v tabulce s možnostmi pod pravým tlačítkem myši


Měsíční přehled (Tabulka)

Vyhodnocení ›› Přehledy ››

Měsíční přehled (Tabulka)

umožňuje zobrazit odpracovanou dobu kumulativně v rámci vybraného měsíce (zobrazí se jen osoby, které mají zadaný úvazek)


Průchody

Vyhodnocení ›› Přehledy ››

Průchody

zobrazí (vytiskne, exportuje) průchody dle zadaných parametrů

Zobrazí seznam průchodů dle zadaných parametrů - filtrů. Záznamy jsou řazeny od nejnovějšího, zaškrtnutá položka "Průchod povolen" = že program vyhodnotil že byl průchod povolen.

Filtrovat lze dle

        1. na úrovni kategorií až po jednotlivé osoby
        2. jednotlivých zámků (zařízení)
        3. období

Nastavení filtrů lze uložit pomocí tlačítka "Uložit filtr" a při příštím vyvolání průchodů budou filtry přednastaveny.

Kromě přehledu průchodů je možné průchody vytisknout a nebo exportovat např. do Excelu a to přes tlačítko "Tisk" v horním menu


Přehled směn

Vyhodnocení ›› Přehledy ››

Přehled směn

zobrazí přehled směn vybraných pracovníků


Přehled přístupu

Vyhodnocení ›› Přehledy ››

Přehled přístupu

zobrazí přehled přístupů


Výkazy

Vyhodnocení ››


Výkaz práce

Vyhodnocení ›› Výkazy ››

Výkaz práce

zobrazí a umožňuje vytisknout výkaz práce pro jednotlivé zaměstnance

na základě navolených úvazků


Podklady ke mzdám

Vyhodnocení ›› Výkazy ››

Podklady ke mzdám

umožňuje tisk hromadného soupisu odpracovaných hodin dle zadaných úvazků


Addiny


Integrace systému Stravné 4

Addiny ››

Integrace systému Stravné 4

pro import osobo z programu Stravné 4

Soubor DBF

- cesta k souboru do kterého program Stravné průběžně ukládá změny (v tom případě jde o soubor DATAPART.DBF, v případě pouze jednorázového importu jde o soubor DATAFULL.DBF)

Vzorová kategorie

- pokud systém při importu nalezne kategorii v exportním souboru, která neexistuje v Bázových datech / Kategorie (jakože v našich kategoriích), potom se nabídne možnost párování importované kategorie na kategorii v Otvíráku

Formát čísel čipu

- Otvírák / BeHere potažmo různé připojení čtečky čipů si interpretují číslo čipu jiným způsobem (a než systém VIS). Aby byla možná vizuální kontrola čísla čipu v programech VIS a Otvírák, je třeba programu říci jakou technologii čipů/karet importujeme z programů VIS.

Protože import bývá málokdy jednorázový, je třeba nezapomenout na nastavení Plánované akce


Import svátků/prázdnin

Addiny ››

Import svátků/prázdnin

Nastavení importu prázdnin, výběr okresu pro Jarní prázdniny a ruční import.

Do programu jsme připravili funkci, která umí využít seznam prázdnin připravený pro Stravné 5 a stáhnout jejich seznam. Pro nastavení je třeba nejdříve nastavit převodní tabulku a zvolit okres pro stažení správného termínu Jarních prázdnin.

Pro úplné nastavení importu svátků/prázdnin je třeba v pravé části vyplnit Kategorie svátku = "JA", správný okres a kategorii prázdnin = "Jarní prázdniny" viz. obrázek

Po uložení změn je možné tlačítkem Import v horní liště stáhnout všechny prázdniny a svátky, které jsou na webu VIS dostupné

Aby nebylo třeba na další importy myslet, je vhodné pokračovat nastavením automatické aktualizace


Transformace tříd

Addiny ››

Transformace tříd

pro posuny tříd dle nového školního roku

tuto funkci využijí organizace, které nenačítají osoby (studenty / žáky) z žádného externího systému a o prázdninách nastává potřeba posunou žáky do vyšších tříd.

Postup je jednoduchý - jedenkrát se vybere Nová třída navazující a původní a nakonec vše potvrdíme resp. uložíme tlačítkem v menu Transformovat a Uložit.

Alternativně lze využít Hromadné funkce v tabulce Osoby


Integrace ŠkolaOnline

Addiny ››

Integrace ŠkolaOnline

pro synchronizaci osob a průchodů

Slouží pro načtení Osob ze systému Škola Online (DMSoft) a zároveň export průchodů zpět do ŠOL pro párování s třídní knihou.

Aby vazba fungovala, organizace si musí nejdříve zažádat o ŠOL (DMSoft) o povolení vazby, na základě které obdrží API URL, API login a API heslo, které se zadají do programu

Další položky by měly být významově jasné.


Integrace systému Bakaláři

Addiny ››

Integrace systému Bakaláři

pro synchronizaci osob a průchodů skrze Datový konektor

Slouží pro načtení Osob ze systému Bakaláři a zároveň export průchodů zpět pro párování s třídní knihou.

Aby vazba fungovala, firma VIS předem žádá o povolení vazby Bakaláře, na základě které obdrží API URL, API login a API heslo, které se zadají do programu

Další položky by měly být významově jasné.


EdooKit nastavení

Addiny ››

EdooKit nastavení

pro synchronizaci osob a průchodů s EdooKitem

Slouží pro načtení Osob ze systému Edookit a zároveň export průchodů zpět pro párování s třídní knihou.

Aby vazba fungovala, je třeba aby u zákazníka pověřená osoba, která má správcovská pověření pro EdooKit založila v EdooKitu API a údaje pro docházkový systém (postup je uveden v nápovědě EdooKi - např kapitola 6 v https://www.edookit.com/content/knowledge/37-rozhrani-pro-dochazkove-systemy/rozhrani-pro-dochazkove-systemy-verze-2-v-2.9-1.pdf. ,

Na základě vygenerování API URL, API login a API heslo se údaje zadají do programu

Další položky by měly být významově jasné.